HELP FILE

System Requirements for Users

    LastPass is supported on the Windows, Mac, Linux, and mobile platforms – so all of your data is stored in a centralized place and is accessible from anywhere, anytime! You can use the LastPass browser extensions, desktop apps, or mobile apps. You can also learn more about virtual environments and the binary component.

    To get started, you can create an account then downloading and installing LastPass for all of your devices.
    Note: LastPass is not supported on sites that run in IE mode.

    Use the LastPass browser extensions

    In order to download and use the LastPass browser extensions from your desktop, your system must meet the following requirements:

    Requirements for Web Browser Extensions Notes & Documentation
    Operating Systems
    • Windows 8.1 or later*
    • The two (2) most recent major macOS versions with a 64-bit processor required
    • Linux
    • Chrome OS

    n/a

    Web Browsers
    • Internet Explorer 11 or later
    • The two (2) most recent versions of the following web browsers:
      • Google Chrome
      • Mozilla Firefox
      • Microsoft Edge
      • Safari
      • Opera

    The LastPass IE web browser extension only receives security updates, compatibility fixes, and technical support, but does not receive new LastPass feature enhancements as it is currently in maintenance mode per Microsoft. Please see https://www.microsoft.com/en-us/microsoft-365/windows/end-of-ie-support for more information.

    Additionally, Enhanced Protected Mode is not supported when using Internet Explorer.

    Internet Connection
    • An internet connection with 1 Mbps or better (broadband recommended)
      Note: ICMP is a required protocol used by LastPass to ping lastpass.com to verify end-to-end connectivity. Additionally, communication with lastpass.com is through HTTPS using port 443 with TLS 1.2.
    n/a

    *For installing the LastPass Universal Installer, .NET Framework 4.52 or later is required on Windows 8.1 or later.

    Use the LastPass desktop apps

    In order to download and use the LastPass for Windows Desktop application or the LastPass Mac App on your desktop, your system must meet the following requirements:

    Requirements for Desktop Apps Documentation
    Operating Systems
    • Windows 8.1 or later
    • The two (2) most recent major macOS versions with a 64-bit processor required
    Internet Connection
    • An internet connection with 1 Mbps or better (broadband recommended)
      Note: ICMP is a required protocol used by LastPass to ping lastpass.com to verify end-to-end connectivity. Additionally, communication with lastpass.com is through HTTPS using port 443 with TLS 1.2.
    n/a

    Use the LastPass mobile apps

    In order to download and use the LastPass mobile apps, your mobile device or tablet must meet the requirements listed below.

    Requirements for Mobile Apps Documentation
    Android Mobile Operating System
    • Android OS 6 (Marshmallow) or later
      • Access to the Play Store app is also required
    iOS Mobile Operating System
    • iOS 13 or later
    Internet Connection 3G (or better) or Wi-Fi n/a

    About virtual environments

    LastPass is not currently supported for use in virtual environments.

    Restriction: Please note that LastPass Support does not provide technical support for LastPass in virtual environments.

    About the binary component

    The binary component is included in the LastPass Universal Installer for Mac and Windows, and is supported on the Chrome, Firefox, Safari, and Opera, desktop web browsers via the web browser extension. Learn more about the binary component.